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Unable to configure ION 8650 Advanced Security User in ION E 6.0

Published date: 19 July 2019

Issue
When adding an ION 8650 with Advanced Security to an ION Enterprise 6.0 system the user is unable to specify one of the Advanced Security users in the Security configuration menu. Only <not specified> and Standard Security are selectable options. Without specifying the Advanced Security password, the software will be unable to access the device. 

Product Line
ION Enterprise 6.0
ION 8650

Environment
ION Enterprise 6.0 Management Console

Cause
The Device Upgrade pack that installs the ION 8650 driver does not properly define the meter as being an Advanced Security meter. Therefore Management Console does not show the Advanced Security users list. 

Resolution
There are two possible resolutions. 

Resolution 1: 
1) Change the device type from ION 8650 to ION 8600. 
2) Configure the Advanced Security user under the Security options. 
3) Change the device type back to ION 8650. 

Note: This will have to be done for each ION 8650 in the system.

Resolution 2: 

*Warning: Irreparable database damage can occur. This procedure should only be performed by users familiar with SQL Server Management Studio. Databases should be backed up prior to performing this procedure.*


1) Backup the ION_Network database
2) In SQL Management Studio, open the dbo.DeviceType table in the ION_Network database. 
3) Find the row that has "8650" as the Type and change the value in the SecurityModules column from 1 to 16. 
4) Close out of Management Studio. 
5) Now all 8650's will give the option to select an Advanced Security user in the Security settings. 

Note: The attached SQL query can be run instead to perform this operation. 

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