Technical FAQs

Ask a Question

Which version of the XBTL1000 software allows programming of XBTR display units?

XBTR400, XBTR410 and XBTR411 display units can be programmed using XBTL1000 software (XBTL1001 or XBTL1003) version V4.4 or later.

Note: This software is now obsolete and no longer supported. The Magelis XBTR range is obsolete


 
Was this helpful?
What can we do to improve the information ?