Technical FAQs

Ask a Question

Is the SFT2841 software, version 8.10, compatible with Windows 95?

No, version 8.10 of the SFT2841 software is not compatible with the Windows 95 operating system. The SFT2841 software must be used with the Windows XP operating system.
Was this helpful?
What can we do to improve the information ?